Bienvenu sur le forum du serveur Francophone Aurora.
L'équipe Aurora souhaite vous offrir le meilleur serveur Star Wars Galaxies de tout les temps. N'hésitez pas a poster au besoin!
Bon jeu à tous et à très Bientôt !

Actuellement certaines adresses ne reçoivent pas le mail de confirmation. Si vous ne l'avez pas reçu, vous pouvez tout de même télécharger le launcher et jouer sur Aurora.
Les admins active les comptes Forum (différents des comptes jeux) dès qu'ils passent sur le forum, ne soyez pas surpris de pouvoir vous connecter au Forum,
quelques heures après votre inscription, même sans réception du mail.

Merci pour votre compréhension.

Voter pour le serveur : https://topg.org/swg-private-servers/in-483512
Merci !!!

Compatibilité avec des machines un peu anciennes

Ici tout ce qui concerne le support sur Aurora
Avatar du membre
TienVogh
Membre
Membre
Messages : 3
Enregistré le : 04 nov. 2018, 18:07
Guilde : BSI
Personnage Principal: : Zeneb LaChannelle
Personnage Secondaire : Tian'no Vogana

Compatibilité avec des machines un peu anciennes

Message non lupar TienVogh » 02 févr. 2019, 19:57

Bonjour,

J'ouvre ce topic pour évoquer des soucis de compatibilité que j'ai constaté entre le client Aurora et des machines un peu anciennes, typiquement des ordinateurs d'une dizaine d'années contemporains du jeu d'origine et sur lesquels le client SWGEmu classique fonctionne sans aucun problème.

Parlons d'abord de ce qui fonctionne : je joue habituellement sur un PC portable LDLC Aurore KZ3 (processeur Intel Core i3, 4 Go de RAM, chipset graphique Intel intégré) acheté il y a un an. Le jeu fonctionne très bien sur cette config, aussi bien sous Windows 10 que sous Linux Debian 9 avec Wine. Mais c'est le PC familial dont je n'ai pas l'usage exclusif (mon fils s'en sert fréquemment pour ses jeux à lui).
Occasionnellement, je ramène donc chez moi mon portable professionnel, un Dell Latitude 7490 récent (processeur Core i5, 16 Go de RAM, chipset graphique Intel intégré) sur lequel le jeu fonctionne aussi très bien. Je peux comme cela laisser des persos macroter tranquillement sans être dérangés. ;)

Maintenant, ce qui ne marche pas : J'ai essayé de faire tourner le jeu sur un PC tour sous Debian 9 (processeur AMD Athlon 64 X2, 2 Go de RAM, carte graphique ATI Radeon X800GT) et ça plante systématiquement lors du chargement des objets après la sélection du personnage avec le message suivant (debug client activé) :

23:21:27: SWGEmu.exe: stage.119798
unknown location : FATAL 2f487a96: CreateTexture failed 2156

23:21:27:

23:21:27: Exception 80000003(-2147483645)=code 00aa1e3f=addr

23:21:27: Generating minidump
23:21:27: SWGEmu.exe-stage.119798-20181211222127.mdmp
23:21:27:

23:21:28: SWGEmu.exe: stage.119798
unknown location : FATAL 2f487a96: CreateTexture failed 2156
unknown location : FATAL be5fbc55: ExceptionHandler invoked

23:21:28:

Le Processus a échoué!
Le processus s'est terminé avec le code retour -2147483645

Ça plante aussi de la même façon sur un portable Dell Latitude E4200 sous Windows 7 datant de 2010 (processeur Intel Core 2, 3 Go de RAM, chipset graphique Intel intégré) donc ce n'est pas spécifique à Linux.

Comme le message d'erreur indique un souci de textures, j'ai pensé que le problème pouvait venir des textures améliorées d'Aurora. Sur le conseil donné par Secrer sur Discord, j'ai donc essayé de commenter dans le fichier swgemu_live.cfg le chargement des fichiers ILM_Aurora. Cela n'a pas été suffisant, mais par essais successifs, j'ai fini par isoler 3 fichiers qui faisaient planter le client : ILM_aurora_2.tre, upg_texture.tre et aur_patch_026.tre .
Avec ces fichiers commentés, le jeu se lance, mais l'absence du fichier aur_patch_026.tre entraîne des défauts rédhibitoires : le radar ne fonctionne plus, affichant seulement une bouillie de pixels en forme de losange et le client plante lorsqu'on essaie d'afficher la carte planétaire.

Voilà où j'en suis dans mes essais. Je ne sais pas comment sont organisées les données du jeu mais les textures améliorées ne devraient-elles pas être cantonnées dans des fichiers spécifiques afin de pouvoir les désactiver au besoin sans perdre des fonctions essentielles ?

Avatar du membre
Totor
Modérateur
Modérateur
Messages : 1750
Enregistré le : 07 févr. 2009, 19:16
Personnage Principal: : Hearine Agenfeld
Personnage Secondaire : Ya'shin Kril

Re: Compatibilité avec des machines un peu anciennes

Message non lupar Totor » 03 févr. 2019, 11:31

Bonjour,

Quelle interface utilises-tu ?
Le patch26 ne dois pas être désactiver avec certaines interfaces. Je dirais même que la désactivation du patch26 va entraîner des problèmes jeu qui te conduiront irrémédiablement à un crash client.

Donc la seule voie que je peux te conseiller c'est de changer d'interface.

Avatar du membre
TienVogh
Membre
Membre
Messages : 3
Enregistré le : 04 nov. 2018, 18:07
Guilde : BSI
Personnage Principal: : Zeneb LaChannelle
Personnage Secondaire : Tian'no Vogana

Re: Compatibilité avec des machines un peu anciennes

Message non lupar TienVogh » 03 févr. 2019, 17:46

J'étais en interface CU. Avec les interfaces pre-CU et NGE, ça marche un peu mieux : le radar fonctionne et il y a juste le fichier ILM_aurora_2.tre que je suis obligé de commenter pour que le jeu se lance. Par contre, la carte planétaire fait planter le client dans tous les cas. Aussi un CreateTexture failed mais avec le code 2154 au lieu de 2156.

Ah, et j'ai aussi eu à deux reprises des crash client sur mon PC portable en utilisant le terminal navette de la station. Une fois reconnecté par contre, ça passait.

Avatar du membre
spharex
Membre
Membre
Messages : 13
Enregistré le : 09 mars 2018, 16:38
Guilde : <AG>
Personnage Principal: : Anthaliane
Personnage Secondaire : Smith

Re: Compatibilité avec des machines un peu anciennes

Message non lupar spharex » 05 févr. 2019, 10:24

les plantages lors du chargement de la map sur la borne de la station sont.. fréquents, dès que tu joues plus de 10-30 min si tu load la map de la borne c'est crash direct systématique, c'est unb ug connu mais qui pour moi n'a rien a voir avec ton soucis premier